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OpenOffice.org Calc
Getting introduced with Calc

Calc is a spreadsheet application in OpenOffice.org suite. In order to open Calc in NepaLinux, there are several ways. But
we just show one particular way i.e. by choosing Applications ->Office-> OpenOffice.org 2.2 Calc
This is shown in Pic.1.
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Pic. 1. Starting OpenOffice.org Calc



When Calc gets started for the first time, it looks like as shown in Pic.2.
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Pic.2. OpenOffice.org Calc window at first startup

Calc is comprised of Worksheets. These worksheets make up the whole spreadsheet document. You can well see three sheets
Sheetl, Sheet2, Sheet3 etc. at the bottom left corner. A worksheet is made up of cells which have two dimensional co-
ordinates as location. Towards the horizontal we have the alphabets and towards the vertical downwards, we have the
numbers. These alphabets and numbers together make up the co-ordinative location of a particular cell. The highlighted cell
is bordered in black and its location can be read by looking at the Name Box located at the upper left corner. In the case of
Pic.2. It is AL. The cells across the horizontal are termed as rows and towards the vertical are named as columns.

You may increase or decrease the size of the column by taking the mouse to the rightmost border of any column by the
alphabet and keep it there till you get a horizontal bidrectional arrow. Then gently press on the left button of your mouse and
drag towards the right or left depending upon whether you would want to increase or decrease the size of the column. This
is shown later in Pic.6.

Please take note that Calc is no different to the popular window applications but just that it is concentrated towards numeric
calculations.

Open and saving the spreadsheet document



This is the same as opening and saving other documents under OpenOffice.org Suite like the writer. The only thing you
would need to be careful is about the format of saving. Please refer to pictures 3 and 4 to be more familiar with saving
formats of spreadsheets.
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Title |Type Size |Date meodified
(3 amsn_received Folder 08/15/2007, 12:58:32
3 bluefish-doc Folder 09/26/2007, 07:25:38
(0 Desktop Folder 10/06/2007, 14:28:13
3 final_electoral_glossary_augl19_07 Folder 08/19/2007, 11:03:01
(3 final_electoral_glossary_ifes_1234 Folder 08/19/2007, 11:01:57
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CJ PAN Folder 08/17/2007, 07:34:35
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[J Trans_Latest Folder 08/21/2007, 07:34:07
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T
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Pic.3. Save as Window

By default, Calc saves the document under the *.ods format. There are several file type options which you can see by
clicking the combo box for File type. For a detailed overview of the file types, please refer to Pic.4.
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Save as
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Title |Type Size |Date modified
[J amsn_received Folder 08/15/2007, 12:58:32
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(1 Desktop Folder 10/06/2007, 14:28:13
3 final_electoral glossary_augl9 07 Folder 08/19/2007, 11:03:01
3 final_electoral glossary_ifes 1234 Folder 08/19/2007, 11:01:57
3 flash_player_9_solaris_r47_sparc Folder 06/19/2007, 08:46:20
3 HRS_Reports_Final Folder 08/18/2007, 01:49:19
(3 install_flash_player 9 linux Folder 06/20/2007, 06:16:08
3 ltsp Folder 08/17/2007, 05:22:14
3 mail.bak Folder 08/15/2007, 06:31:16
CJ PAN Folder 08/17/2007, 07:34:35
[3J to_binod nlp_reports Folder 08/20/2007, 05:00:45
(3 Trans_Latest Folder 08/21/2007, 07:34:07
File name: | | - | Save
File type: DpenDocument Spreadsheet (.ods) |+ cancel ‘

OpenDocument Spreadsheet (.ods)

OpenDocument Spreadsheet Template (.ots) Help ‘
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Pic.4. File types for saving a spreadsheet document

As you can see above, there are a number of file types. But if you plan to work later with the spreadsheet document in the

Microsoft Excel 97/2000/XP Template (.xlt)

Microsoft Excel 95 (.xls)
Microsoft Excel 95 Template (.xlt)

»

-]

Windows operating system, you are advised to save the document in Microsoft Excel 97/2000/XP (.xls).

Navigating across work sheets

Assingle click on any of the sheets shown in Pic. 2. would lead to you to the particular sheet. The sheet under focus is
highted in bold text.If you right click on the selected sheet, you will see a popup contextual menu with several submenus.
This is shown in Pic.5.
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Pic.5. Contextual popup menu on right clicking the sheet

As shown in the menu above in Pic.5, you may insert an additional number of sheet to the spreadsheet document, delete

sheet, rename the sheet and so on.

Entering and editing number and text

You can enter and edit number and text by two ways, either by entering directly in the cells or in the Input line, which

is a text box just above the horizontal line of alphabets. This is shown in Pic. 6.



calc_test.ods - OpenOfhice.org Calc

File Edit WView Insert Format Tools Data Window Help

B-oEaoBRaEs ©% s8-8 §- Qiie P R4-BEBQ @ .

H NimbusSan:_ ~| |10 ~| [&] [&] [&] |W|1]< B sximd EE H-®E-RA-
cs X =)

4 Playing around with Cale

7 Entering numbers in increasing order Entering the same number multiple times

8 1 1L

10
13
14
15
16
17 10
18 1
19
20
21
22
23
24
25
20 <]
w1 v\ Sheetl {Sheetz 7Sheets 7 1] I Dl
Sheet1/3 Default 100% STD x Sum=1

Pic.6. Entering and editing numbers and texts

For entering numbers in increasing order or the same number multiple times, you may opt to enter the numbers manually or
make use of an available utility in Calc.

For entering numbers in increasing order

Just enter 1 in one of these cells. Then take your mouse to the rightmost bottom corner of the cell, where you have entered
1. Make sure the cursor of your mouse changes into + sign. Then gently press the left button and drag the cursor down the
cells to as many number you would want to get displayed.

For entering the same number multiple times

Enter the number, say 1 in two of the cells. Select both of the cells and repeat the same process as mentioned above.

Undoing changes

Undoing changes in Calc would have the same effect as with any window application. You may undo changes by either
choosing Edit->Undo or by pressing Ctrl+Z.



Work sheets
Naming a work sheet

Naming a worksheet is as simple as clicking on the Rename Sheet menu from the contextual menu shown in Pic. 5. As a
result you are displayed the following window as shown in Pic.7.
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Pic. 7. Renaming Sheetl
Please take the liberty of putting any name to the sheet as long as it makes sense.
Entering the headers in the rows and columns

By headers, we understand some sensible naming for the whole row or column. So the header should be something sensible
and marked in bold for distinction. In Pic. 6. the texts , "Entering the numbers in increasing order" and "Entering the same
number multiple times" could be well regarded as headers.

Aligning the text
Aligning text in Calc is the same as any window application. Just the thing is in case of Calc, the text get aligned with
respect to the cell(s).

Enabling automatic control over the type of data being entered

In Calc, you can automatically control over the type of data being entered. For instance, if you have got number format with
decimal places but in fact you would want Calc to take care of the rounding and return back rounded figures. What you can
do is select some cells and click on the "Number format: Delete Decimal Places" button in the formatting menu toolbar. The
result is shown in Pic. 8. Although you entered 95.5 as shown in the Input line text, Calc automatically rounded the figure to
96.
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Pic.8. Automatic control over the entry of the data

This sort of automatic control may be applied to currency, percentage and other number formats as well by clicking on the
respective format buttons in the format menu tool bar panel.

Previewing and printing the work sheet

The worksheet may be previewed by following the standard selection : File-> Page Preview or directly clicking on the Page
Preview Button on the standard menu tool bar. Inorder to print the worksheet, you would need to select File->Print as with
any standard window application.

Adding pictures to the work sheet

Adding pictures to the worksheet of Calc is the same as with any other standard window application. Pic.9. shows the
inserted picture in the worksheet.
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Pic. 9. Adding picture to the worksheet

Using formulae

Using formulae is an important part of any spreadsheet application.

Adding formulae to the work sheet

For illustration, we present here the simple SUM function. As shown in Pic.10, we first enter the numbers in the cells. Then
begin typing the formula for SUM in the immediately following cell, i.e. =SUM(B5:B13). The SUM function carries two

arguments, one is the starting cell and the ending cell with a ":" in the middle indicating the range. As we see, the sum
function calculates the sum of the entered numbers.

10
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Pic. 10. Illustrating a simple function SUM()

Copying formula to other cells

We again take the example of the SUM() function to illustrate this. Please refer to Pic. 11. before we get engaged in some
further discussions on this.
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Pic.11. Copying formula to other cells

As you can notice, the formula SUM() is only defined at cell F17. In order to find the sum of the numbers in the next row in
cell F18, it is sufficient to select the cell with the formula i.e F17 in this case and drag it to the next cell F18. This sums the
number in the next row as well.

Preparing the work sheet

Formatting the cells manually or using styles

You may format the cells manually or using style. For manual formatting, you may use a number of formatting elements

found in the format menu toolbar. In order to use styles, you would need to select Format->Styles and Formatting or simply
by pressing F11. As a result, the following window is displayed as shown in Pic.12.

12



Styles and Formatting
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Pic.12. Styles and formatting window

In Pic.13. we see the application of the result format to the SUM and Sum of marks headers.
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Pic. 13. Application of style formats

100% STD *

Formatting numbers as well as 4 digit symbols like dates

You may choose your custom format by selecting a cell and right clicking it. You would be displayed the following window

as shown in Pic.14.
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b= Format Cells b

|Number5| Font | Font Effects | Alignment | Borders | Background | Cell Protection |

Category Format Language
All 12/31/99 -] |Default : |
User-defined Friday, December 31, 1999 I
Number 12/31/99
Percent 12/31/1999
Currency Dec 31, 99
Dec 31, 1999
31. Dec. 1999
Scientific =] December 31, 1999 o 10/06/2007
. 31 Neremher 10949

e [l
P fl

Format code

MM/DD/YYYY

oK |Cance| H Help || Reset ‘

Pic. 14. Format cells window

In the format cell window, you may set several things like the date for instance. In the above case, the date format has been
set to MM/DD/YYYY i.e. month/day/year format and hence the cell where this format is applied will take the date
specifically in this format.

Saving the spreadsheet as a template

If you want to save your spreadsheet as a template, you may choose to save it as either one of the following formats like .xIt,
.stc and .ots as shown in Pic.4.
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